Laravel, MCRYPT and OSX

So today I am totally over using Mac OS X built in Apache server. I initially used MAMP, but when playing with Laravel – I couldn’t get PHP MCRYPT enabled to use artisan / composer in the terminal.

After updated and installing MCRYPT on my local version of Apache, I was burdened with creating virtual hosts every project. It seems that as much as I try to automate, I make more work.

Not giving up – it turns out  the issue was my bash_profile is looking at the wrong version of PHP. It was looking at the installed with OSX version when MAMP already has it installed.

More information is here: http://stackoverflow.com/questions/16830405/laravel-requires-the-mcrypt-php-extension – omg thank the internets.

 

Leave a Reply